New Page 1

此网页使用了框架，但您的浏览器不支持框架。


OStar屏幕组成

新建普通文件

单击欢迎屏幕上的“新文档”，开始建立一个新的“办公之星”文件；系统默认文件名为“Ost1”；

单击常用工具栏里“新建”按钮“ [image] ” ,也可以快速地建立一个新的文件。还可以按 Ctrl + N 键，来快速建立一个新文件。

办公之星在第一个建立的文件标题栏中显示“Ost1”，以后建立的新文件的序号递增，即“Ost２”、“Ost３”……，当打开一个新建的文件之后，在标题栏就显示出该文件的文件名。

办公之星自动打开的“Ost1”窗口会被新建的“Ost２”窗口所覆盖，这时“Ost1”窗口实际并未关闭。如果要切换到“Ost1”窗口中，可以单击“窗口”菜单，选择“Ost1”命令，或通过文件切换工具条即可返回到“Ost1”窗口。

上级目录


OStar屏幕组成

利用模板创建新文件

单击主菜单栏里的“文件 ＞ 新建”，对话框显示内建的一些常用模板（如上图示），同时右边预览栏显示出模板文件的内容，单击某一个模板文件，就可以打开该文件。用户可以利用该模板文件的一些固定模式来建立一个新的文件，这样可以节省大量的时间；同时用户还可以将某个模板文件设置为默认模板，这样，系统以后每次启动时，单击“新建”，就会自动打开该文件作为新建文件的模板。

上级目录


OStar屏幕组成

打开文件

◆单击“文件”菜单，菜单的最下面列出最近使用过的文件（最多能保留５个），光标单击相应的文件名或键入文件名前相对应的数字，就可以直接打开该文件。

◆单击欢迎屏幕上的“打开上次编辑的文档”，系统将会自动打开上次关闭系统时最后编辑过的文档；

◆单击“打开文档”或者单击主菜单栏里“文件＞打开”，系统将打开指定了路径和文件名的文档；单击常用工具栏里的打开文件按钮 “ [image] ”也可。

上级目录


OStar屏幕组成

发送邮件

在“办公之星”的主菜单里，有一个非常实用的功能：发送邮件。这对于用户通过网络处理电子邮件有着非常重要的作用。单击“文件”菜单，从中选择“发送邮件”命令，系统启动Outlook建立一个新邮件。并已将当前的办公之星文件作为附件。填写好相关内容按“发送”按钮即可。

上级目录


New Page 2

此网页使用了框架，但您的浏览器不支持框架。


移动光标

文字处理

移动光标

选定文本

移动文本

复制文本

段落缩进

段落对齐


文字格式

改变字体

改变字号

改变字型

设置斜体、粗体、删除线

添加下划线、字符底纹、上、下角标及超级链接


编辑表格数据

定位单元格

编 辑和消除单元格数据

移动和复制单元格数据

系统目录


移动和复制单元格数据

⑴ 选定需要移动的单元格或范围；

⑵ 单击“编辑”菜单，从中选择“剪切”选项。还有一种方法是单击鼠标右键，从弹出的快捷菜单中选定“剪切”选项。

⑶ 选定要粘贴区域的左上方单元格；

⑷ 单击“编辑”菜单，然后单击“粘贴”选项。

上级目录

系统目录


修改表格

改变行高和列宽

增加、删除行与列

合并表元

分解表元

表元批注

合并表格

分割表格

手工绘制表格

擦除表格线

系统目录


分解表元

⑴ 双击表格，使之处于编辑状态。

⑵ 选定要分解的所有单个表元。

⑶ 单击“表格”菜单，在弹出的菜单中选择或“分解表元”命令，或单击“表格工具栏”上的“分解表元”按钮“ [image] ”，弹出一对话框。

⑷ 在对话框的“行数"框中输入选定表元要拆分的行数。“列数”框中输入选定表元要拆分的列数。

⑸ 单击“确定”按钮，选定表元就拆分成多个表元。

上级目录

系统目录


合并表格

◆选中需要合并的两个表格;

◆在“表格工具条”上选中按钮“ [image] ”或“ [image] ”即可。

上级目录

系统目录


合并表格

分割表格

分割时是以所选中单个表元的上边框和左边框为基准进行的。因此在选中第一行和第一列的表格是不能进行分割的，选中多个也不能进行。其具体操作步骤如下：

1）选择合适的单个表元；

2）在“表格”菜单中单击“分割表格”选项，在弹出的子菜单中有二个选项：“水平分割”和“垂直分割”，选择一个选项。或者直接表格工具条中选择按钮“ [image] ”（水平分割表格按钮）或“ [image] ”（垂直分割表格按钮）。此时，表格即按要求分成二个。

上级目录

系统目录


手工绘制表格

利用“表格工具”条上“绘制表格”按钮“ [image] ”,您可随心所欲地绘制复杂的表格，如绘制表元斜线、垂直线或水平线。使用“绘制表格”之笔的方法:先击活表格，然后按一下“ [image] ”，即可以在表格里随意画表线。

上级目录

系统目录


手工绘制表格

擦除表格线

1) 双击表格，使其处于编辑状态；
2) 选取“表格工具条”中 “擦表格线”工具“ [image] ”，此时在表格范围内鼠标成为一橡皮擦形状；
3) 在欲擦除的表元线上单击，此时此表元线由黑色变为灰色显示，如需擦除多处，多次进行单击操作；
4) 在表格外单击，使其退出编辑状态，即可看见擦除效果。

需要注意的是，此操作仅改变表格中表元线的显示效果，并不增减表元的数量。如欲擦除表元斜线，请选将斜线选中，然后按“Delete”键即可。

上级目录

系统目录


表格数据处理

表元的位置引用

自定义公式

函数介绍

自动计算

填充公式

跨表格计算

跨工作表计算

灌入数据

数据排序

系统目录


办公之星简介


办公之星是一套运行在Win95

办公之星是一套运行在Win95/98/2000上的办公软件，她结合了字处理、电子表格、辅助管理等诸多功能，她实实在在帮助用户提高工作效率，解决工作中所遇到的问题，特别引入的辅助管理功能，它解决了在局域网下“如何集体办公”的难题。办公之星的出现极可能引起一场办公方式的革命！

办公之星的易用性非常好，如你使用过其它字处理软件或电子表软件，则你不用学就可以熟练使用办公之星，因为办公之星所有操作都与这些软件相兼容，完全不必担心使用上有任何困难。

办公之星的实用性非常强，她的所有功能都以用户实际应用出发，她摈弃了华而不实的功能，完全符合国人办公事务处理的习惯。

下面让我们来看看“办公之星”软件的主要功能及特点：

● 倾心的界面

“办公之星”的界面完全融合流行潮流，工具条采用最新的平面式按钮，所有的对话框界面控件都是立体动态方式；“办公之星”的文件切换工具条可以快速地切换打开的文件，而文件库可以迅速打开文件，并且方便管理你的各种文件，从而避免频频打开文件管理器；在选择字体名称或字体大小时，有个窗口小精灵会动态显示字体的效果；独创的标尺结合了Word 标尺和Excel行列标识功能，在一般情况下，动态显示对象的尺寸，当表格处于编辑状态时，标尺将自动转换成行列标识工具条，从而方便选中表格的整行或整列。如觉得屏幕不够宽阔，用户可以选择全屏幕方式。在“办公之星”里可以生成多个工作表，你可以按分类把表格放在不同的工作表里，从而避免生成过多的文件。

● 文字处理

办公之星的先进图文混排技术，可以制作各种复杂的文档。直接可以在页面上输入文字，自动增减页面；可以对页面文字进行各种处理，如改变字体、字号、加粗、倾斜、加下划斜等等，可以对段落进行居左、居中、居右、匀齐等操作。在办公之星里，可以对各种对象进行随文和绕排处理。办公之星文字处理的鼠标操作全部兼容了其它办公软件，如可以直接用鼠标拖动文字，鼠标选块等。此外，办公之星的文字艺术处理功能将会使你的文档更加生色，艺术处理包括了阴影、空心、立体、阴/阳文等。

● 制表方便

制作表格是办公软件的基本功能，也是重点功能，“办公之星”对表格制作提供了全面的支持，能够制作复杂的表格。使用“插入表格”按钮，可以快捷地创建你所需的表格；“绘制表格”之笔可以使用户随心所欲地绘制复杂的表格，如绘制表元斜线、垂直线和水平线。表格功能非常丰富，可以进行合并/分割表格、合并/分解表元、插入行或列、删除行或列、各行等高、各列等宽、微调各行各列的宽高、任意移动表元线等等操作。“办公之星”的表元功能相当强大。表元可以设置多种属性，即不同的表元文字可以有不同的字体和颜色等；也可以对表元文字进行各种对齐操作，如居右、居中、居左和匀齐等。特别值得一提的是，可以轻易在表元里实现上下标。在表元格式方面，表元能设置成显示小数位数、货币符号、百分比、千分位隔等格式。“办公之星”的斜线表元相当有特色，可以用笔在表元里随意画斜线，并且可以直接输入斜线表元文字和旋转斜线表元文字。如担心表元内容被修改，你可以把表元设置为保护状态。另外你可以把各种对象粘贴到表元里，如粘贴的是一个表格，则就能实现表中表。 当你想美化一下表格时，你可以改变表框线的线型和颜色、用颜色或图片为表格添加漂亮的背景，或直接套用表格外观格式。

● 强大的数据处理功能

办公之星强大的数据处理功能包括公式计算、排序、表元填充、灌入数据、邮件合并等功能。办公之星通过指点式输入公式，支持跨表格和跨工作计算；当改变某一表元时，将会自动重算与该表元相关的公式。办公之星提供的大量函数，方便你进行各种类型的计算。另外，办公之星可以打开各种流行的数据库文件，并且办公之星的邮件合并功能实现了跟数据库的无缝连接。

● 美观的图表

图表是分析数据的最直观方式，办公之星能够根据表格数据自动生成各种类型的美观图表，如柱形图、棱锥图、折线图、饼图等图表，并且各种图表可以互相转换。图表与生成它们的表格数据相链接。当修改表格数据时，图表会自动刷新。大部分图表都是三维的，如你想图表更醒目，可以改变它的颜色、线型等。

● 丰富的对象

办公之星提供的对象非常多，有文字框、文字圆、各种类型的图形、图片、控件、OLE对象等等。办公之星的文字框功能非常强大，可以对不同的文字设置不同的属性，如字体名称、字体大小、颜色等；可以设置不同的段落属性、对齐方式。文字框支持文字块拖动、双击选词等操作。在我们工作中，通常用数字加个圆圈来标明顺序，而极少软件有此功能，现在办公之星的文字圆可以轻易实现这样的功能。

● 完美的打印

“办公之星”的完美打印功能完全可以满足你的需要。每个对象都可设置为打印或非打印状态；“办公之星”的表格套打功能可以广泛应用于各行各业的票据打印；反片打印功能可满足印刷行业的需要；特大页面打印功能可以打印大幅面的公告、海报、标语等；平铺打印可以打印名片、卡证等。此外，打印选择对象、缩放打印等打印功能都是用户常用的功能。

● 高效率的自动指令

在商业社会，讲求的是效率，通常都希望我们的工作都是高效率。现在“办公之星”的自动指令正为此需求而产生。通过自动指令，你可以把几步操作变为一步操作，从而大大提高效率。使用自动指令不需要用户懂得编程知识，简单易用。通过自动指令，用户可以根据自身业务需要，定制自己的办公管理系统，从而不必要花钱请人来另定造一套。如用户拥有局域网，则可利用办公之星定制的办公管理系统进行集体网上办公。(注：在“办公之星”的范例里有通过使用宏指令来定制的公司办公系统、学校办公系统等)。

● 其它功能

“办公之星”提供了许多标准功能，如撤消/重复(Undo/Redo)、断电保护、各行各业的模板、阅读权限、改变页面背景、插入页号/页脚/页眉、查找/替换、更改启动封面等功能。办公之星能够完美读取由Word、WPS等办公软件生成的RTF文件。另外，利用办公之星可以快速起草公文，定制公章。

● 总结

“办公之星”软件是一个经过严密的市场调查、科学的研发而诞生的软件。在调研过程中，自始至终地坚持“用户第一”的原则。由于软件结构严谨及采用了先进的开发技术，使得“办公之星”运行相当稳定。

上级目录


OStar屏幕组成


New Page 2

◆窗口的最上面是”标题栏"，显示的是软件的名称与现在正打开的文件。

◆在菜单下面是工具条与格式条，对象工具可以在窗口上浮动。

◆在文件窗口的左边与上面显示了标尺。

◆状态行置于窗口的底部，用于显示当前插入点位置或命令提示。

使用"视图"菜单中的命令可以显示或隐藏界面上的工具条、标尺与状态行。可以根据需要隐藏这些工具，使编辑页面的范围扩大。例如:在输入编辑文字时，可以隐藏图形工具与对象工具，在需要时显示。

如果工具条中的图标或菜单中的命令项变成灰色，表示在当前状态下该命令无效。

单击“视图”菜单，在出现的菜单项中，如果前面有对勾符号“ [image] ”，表明这一项已经显示在屏幕上；如果单击一下，该项目就出现在屏幕上，再单击一下，又会从屏幕上消失。

上级目录


OStar屏幕组成

欢迎屏幕


New Page 2

“办公之星”在启动时，会显示欢迎屏幕如下图所示：

◆新文档：建立新的文件；

◆打开上次编辑的文档：打开上次存盘的文档；

◆打开文档：打开指定的文件；

◆模板：打开模板，您可利用模板建立新的文件；

◆自我介绍：介绍了“办公之星”的功能；

◆帮助：打开办公之星帮助系统。

◆启动时显示这个屏幕：如果您不喜欢每次都出现这个窗口，您可以在这个选项前面的方框中单击一下，去掉里面的勾；

◆主页地址：启动Internet Explorer 浏览器，链接到我公司网站；

◆技术支持：建立一个新邮件，您在这里可以将在使用办公之星过程中碰到的疑惑或建议以及有关的问题向我们提出，我们会尽快给您满意的答复。

上级目录


OStar屏幕组成

保存文件


New Page 2

◆保存当前文件：单击主菜单栏“文件＞保存”，系统将当前文件以不改变文件名、格式和存盘位置的方式保存起来。另外，单击工具条上的“ [image] ”，或直接按 Ctrl + S 键也可。

◆将当前文件换名换址存盘：单击主菜单栏“文件＞另存为…”系统将当前文件以新的文件名、保存类型和新的存盘位置保存起来。

◆保存所有文件：“办公之星”一次可以打开多个文件，当打开了多个文件时，单击主菜单栏里“文件＞保存所有文件”，系统将所有被打开的文件以不改变文件名 、格式和存盘位置的方式保存起来。

◆保存为模板文件：

如果当前编辑的文件是模板文件，单击“文件”菜单中的“文件存盘”命令，可直接将文件保存为模板。

如果当前编辑的文件不是模板文件，在保存的时候只要将它保存在安装目录下面的 Template 子目录中，它就成了一个模板文件。以后从“文件”菜单中选择“建立新文件”命令时，可以在创建新文件的对话框中看到所保存的模板。但这时还看不到模板的预览图。为了能够预览，我们必须将模板的内容存为位图文件也同样放到系统安装目录下面的 Template 子目录中。

◆自动存盘 ：为了能够尽量减少突然断电、系统死机等情况造成的损失，办公之星中提供了一个特殊的功能－自动存盘。这时如果出现异外情况，损失的只是上次自动存盘以后修改过的内容。

在“工具”下拉菜单中选择“选项…”子命令，弹出一对话框如上图所示。其中有一项“自动存盘间隔”。在此框内输入一个值，这个值表示每隔多长时间自动保存一下文件，可以根据自己的工作需要设定。如果计算机性能较好，可以将时间设置的短一些，这样，当出现问题时，损失会小一些；如果计算机性能比较差，应该将时间设置长一些。

上级目录


OStar屏幕组成

页面设置


New Page 2

单击主菜单“文件＞页面设置…”或将鼠标移到工作表空白处单击鼠标右键，选择“页面设置…”，此时，弹出一对话框如下图所示：

◆ 纸张规格：每次打开一个空文档，缺省的纸张大小为A4。单击“纸张规格”旁边的下拉列表框，可见到办公之星支持的所有纸张类型。单击一种纸张类型，在“宽”与“高”框显示出该类型的高度与宽度。

◆ 纸张方向：有“纵向”与“横向”这两个选项。在预览”框中就显示出改变之后的效果。

◆页面边距：我们不可能将整张纸都写上字，在一张纸上，上下左右都要留空，留出来的空余宽度就是页面边距。

◆页面背景：包括背景颜色和图片，在设置背景图片中有四个选项：无、居中、拉伸、平铺。在切换以及取消背景图片时应首先选择“无”选项。

◆页面分栏：可调整分栏数以及栏间间距，最多可分为五栏。

◆文字行线：在页面上画上一行行整齐的横线，可自行设置线的颜色。

上级目录


OStar屏幕组成

工作表操作


New Page 2

在办公之星中，文件是可由一个工作表组成，也可以由多个工作表组成。我们在工作表中编辑各种文本，插入表格、图形、图像等各种对象。一个工作表可以有多个页面。在多个工作表组成的文件中，只要用鼠标单击工作表名字标签，相应的工作表就从后面显示到屏幕上来，原来的工作表就隐藏起来。

插入工作表

●单击“插入”菜单，然后单击“工作表”选项，在弹出的子菜单中选择“插入工作表”选项。

●用鼠标右键单击任一工作表标签，在弹出的快捷菜单中单击“插入工作表”选项。

删除工作表

●单击“插入”菜单，然后单击“工作表”选项，在弹出的子菜单中选择“删除工作表”选项。

●用鼠标右键单击任一工作表标签，在弹出的快捷菜单中单击“删除工作表”选项。

重命名工作表

●单击“插入”菜单，然后单击“工作表”选项，在弹出的子菜单中选择“重命名”选项。或者用鼠标右键单击任一工作表标签，在弹出的快捷菜单中单击“重命名”选项。

上级目录


文件库


文件库是用来将已完成的

◆打开文件：文件库是用来将已完成的“办公之星”文件分门别类的组织在一起，有点像Windows下的资源管理器，如下图所示。但它是以“工程>文件夹>...>文件夹>文件"这样的结构组织文件。要对某个文件进行操作时，只需用鼠标单击该文件，该文件就会很快显示在右边文档操作窗口中。这样既方便对文件的操作，又可以节省工作时间。

◆文件库的打开与关闭： 将鼠标移到工具栏里，单击鼠标右键弹出如下图所示菜单，选择文件库前的开关选项，可以选择文件库的打开与关闭；另一种就是直接用鼠标单击常用工具栏里的文件库开关按钮 [image] ，也可以选择文件库的打开与关闭；

◆建立新工程：将鼠标移到文件库里，在空白处单击鼠标右键，弹出如下图所示的菜单:

选择“新工程"后，弹出一对话框。要您输入新工程的名字，输入完成后单击确定，一个新的工程就建立好了。

将鼠标移到文件库里某一工程或文件夹的图标上，单击鼠标右键，弹出菜单如下图所示：

◆建立新文件夹：选择“新文件夹"选项，将在该工程或文件夹下,建立一个新的文件夹；

◆增加文件：选择“增加文件…”选项，将指定的文件加入到该工程或文件夹下；

◆重命名：选择“重命名”选项，将该工程或文件夹重新更名；

◆删除：选择“删除”选项，将该工程或文件夹删除。

上级目录


百宝箱


除了文件库外

除了文件库外，“办公之星”另一个实用而又独特的功能——百宝箱，它可以将用户绘制的图形或符号放入到里面存放起来，当需要使用时，只须从百宝箱（如右图）取出即可。它以不同的类别保存这些符号、图形、图像等对象。

u 应用对象：从百宝箱上方的分类中选择对象的类别。不同的类别，在百宝箱的空白处对应显示不同对象的缩略图。用鼠标双击对象，该对象便插入到编辑区中。
u 添加对象：在页面编辑区单击或添加的对象，此时对象四周出现八个黑色小方块操作点。
 从百宝箱上方的分类中选择您放入对象的类别。
然后用鼠标在百宝箱空白处右键单击（或单击百宝箱右上角的快捷按钮 [image] ），此时弹出一快捷菜单如下图示：

选中其中的“添加对象”命令，此时对象便以缩略图的形式出现在百宝箱中。

u 删除选中对象：用鼠标单击选中欲删除的对象，单击右键，在弹出的快捷菜单中选择“删除选中对象”命令；
u 增加分类：用户可以依自己的实际情况建立新的对象分类，在右键快捷菜单中选择“增加分类”命令即可。在分类列表中新增加的分类排在最后；
u 删除当前分类：对于已存在的分类，用户可以通过“删除当前分类”对其进行删除操作。请慎用此项操作，它将删除该分类中所有对象；
u 重命名分类：如果您认为分类名字并不贴切，可重新命名，它是对当前分类进行的操作。

上级目录


定制界面


定制启动画面

在“办公之星”的目录下，用户可以看到一个 FACE.BMP 的位图文件，这就是“办公之星”启动时的启动画面，用户可以用自己喜爱的位图文件来代替该位图文件，从而定制自己喜爱的启动画面。

定制初始文件

在打开“办公之星”时，系统初始的文件为一个新文件，文件名为 Ost1 。但用户也可以将自己用得很频繁的文件定制为系统初始的文件，这样用户每次进入本系统时，就可以自动打开该文件，以便提高工作效率。在“办公之星”的目录下，有一个 AutoOpen 的文件夹，用户可以将自己用得非常频繁的文件放到该目录下，这样系统每次启动时，将会自动打开该目录下的所有文件。（注意：当该目录下的文件有多个，系统启动时将会同时打开这多个文件）

上级目录


OStar屏幕组成

设置文件密码与信息


New Page 2

设置文件密码

1） 点击“文件”菜单中“设置文件密码”命令，此时弹出一对话框如下图所示:

2) 在对话框的密码栏处输入您设定的密码后确定，又弹出一对话框。重新输入您刚才输入的密码再确定。这样，下次您以及他人打开这个文件的时候只有正确输入了密码后才允许打开。

如要清除密码，按“清除密码”即可。

文件信息

在办公之星中可对文件相关的一些诸如作者，关键词等信息进行设置。选择“文件”菜单中的“文件信息”命令，弹出一对话框如下图所示：

在这个对话框中只有一个选项卡，里面有许多有关文件的栏目，在里面进行填写后，单击“确定”按钮即可。通过它可以对文件本身有更多的了解。

上级目录


OStar屏幕组成

标尺


New Page 2

在办公之星编辑窗口的上面与左边分别有一个标尺，称为水平标尺与垂直标尺。如果您在屏幕上没有见到这两个标尺，请单击“视图”菜单中的“水平标尺”和“垂直标尺”命令，之后标尺就显示在屏幕上，如下图示:

标尺分为水平标尺和垂直标尺。随着所编辑对象的不同，办公之星的标尺能够自适应文本编辑与表格编辑状态。在文本编辑状态，标尺显示为文件版面长度的度量、鼠标的位置等信息。在表格编辑状态，标尺为表格的行列号。

上级目录


文字框


插入文字框

●单击主菜单栏里“插入＞文字框”，鼠标箭头变成一个“＋”形;

●将“＋”形鼠标箭头移到需插入文本的位置，按下鼠标左键的同时移动鼠标，屏幕上可以看到一个随着鼠标拖动时形成的虚线矩形框（如下图）;

●将虚线框拖动到合适大小，松开鼠标，屏幕上显示出一个由八个黑色小方块围成的框架，同时，光标成“|”形自动停留在这个框架的左上角，这个框架即是文字框，此时可以从光标处开始输入文本。

此外，可以用鼠标单击常用工具栏里的“插入文字框”快捷按钮“ [image] ”来插入文字框。

调整文字框大小

●将鼠移到文字框右边的中间黑色小方块上向左右拖动，可以调整文字框的宽度；

●将鼠标移到文字框下边的中间黑色小方块上向上下拖动，可以调整文字框的高度；

●将鼠标移到文字框右下角的黑色小方块上拖动，可以同时调整文字框的高度和宽度。

文字框属性

右键单击文字框，从弹出的快捷菜单中选择“文字框属性”命令后，将弹出一对话框如下图所示。

●“位置尺寸”选项卡：精确调整文本框在屏幕上的位置以及大小；

●“外观”选项卡：改变文本框边线的线型、颜色，填充颜色、图片、图案；

●“其它”选项卡：设置文本框不被打印以及是否可以移动。

上级目录


选定文本


选中某些内容的操作

选中某些内容的操作，称为选定。被选定的内容一般反白显示在屏幕上。

用鼠标选定文本

首先选定文本框，然后将鼠标指针移动到要选定的文本区域之前，按住鼠标左键拖动到选定区域的末端，松开鼠标左键，即可把拖动过的区域选中。在文本所在行双击鼠标，可选定插入点所在行。

使用键盘选定文本

如果要使用键盘选定文本，可在按住 Shift 键的同时，使用移动插入点的组合键，便可以将选定的范围扩展到插入点所移动的位置，见下表:

扩展选定范围

使用键

扩展选定范围

使用键

右边一个字符

Shift + →

向上一行

Shift + ↑

左边一个字符

Shift + ←

向下一行

Shift + ↓

行尾

Shift + End

行首

Shift + Home

上级目录

系统目录


移动文本


移到光标

移动光标


有两种改变光标位置的方式

有两种改变光标位置的方式：一种是用键盘操作，另外一种是用鼠标来操作。

键盘移动光标

键盘 | 插入点移动 | 键盘 | 插入点移动
→ | 插入点右移一个字符 | End | 插入点移至当前行末
← | 插入点左移一个字符 | Home | 插入点移至当前行头
↑ | 插入点上移一行 | Ctrl + End | 插入点移至当前所在页尾
↓ | 插入点下移一行 | Ctrl + Home | 插入点移至当前所在页头

鼠标移动光标

如果要将插入点移动到当前窗口内任一字符位置，只需先将该字符所在的文本框选中（在文本中任一处单击，文本周围出现一些小黑方块形状的操作点即可）后在该字符处单击鼠标左键。

用鼠标左键按着编辑窗口右边的滚动条上的滚动按钮：“ [image] ”和“ [image] ”，可使屏幕上下滚动一行。对准滚动条中的方块按下鼠标左键，将显示当前的页码，拖动该方块，可以一页一页地滚动。但要注意的是，在使用滚动条滚动屏幕进，不改变当前插入点的位置，即插入点可以不在当前显示的窗口内，而是滚动到不可见的位置。

滚动动相应的位置后，需重新选取过插入点，否则当您直接输入文字或按键盘，又会返回到插入点所在的位置。

上 级目录

系统目录


使用剪切板移动文本

● 选定要复制或要移动的内容；
● 选定“剪取”按钮，或按Ctrl + X 键，把剪取的文本存放到剪切板上；
● 将插入点设置到新的位置。如果是在不同的文档间移动内容，将活动文档切换到另外一个文档中；如果是在不同的应用程序间移动内容，打开并切换到另外一个程序；
● 单击“粘贴”按钮或按 Ctrl + V 键。

使用拖放来移动文本

● 选定要移动的文字或对象；
 ● 指向选定的文字或对象，按着鼠标左键拖动鼠标指针，指针变成了“ [image] ”，拖动对象到新位置后松开左键，就可完成移动操作。

使用鼠标右键移动文本

● 用鼠标选中需要移动的文本或对象；

● 用鼠标右键单击选定的内容，将弹出一个快捷菜单，如下图示；

● 选择菜单中的“剪取”命令，把选定的文本或对象放入剪切板中；

● 用鼠标右键单击要插入的位置，在弹出的菜单中选取“粘贴”即可。

上级目录

系统目录


复制文本


使用

使用“剪切板”复制文本

● 选定要复制或移动的内容;

● 单击“复制”按钮，也可按 Ctrl + C键，把复制的文本放在剪切板上；

● 将插入点设置到新的位置，如果是在不同的文档间复制内容，将活动文档切换到另外一个文档中。如果是在不同的应用程序间复制内容，打开并切换到另外一个应用程序中；

● 单击“粘贴”按钮或按 Ctrl + V 键。

使用拖放操作复制文本

● 选定要复制的文字或对象；

● 按住 Ctrl 键，将鼠标指针移动到选定的文字或对象上面，按下鼠标左键拖动；

● 当光标到达新位置时，松开鼠标，再放开 Ctrl 键，即可将选定的文本或对象复制到新位置上。

上级目录

系统目录


复制文本

段落缩进


使用

在办公之星中每段的首行缩进值默认为两个字符，也许有时您并不希望出现缩进。这时您可以按照下列方法取消它：

1) 选定要取消缩进的段落，如果只是一个段落，那么只要使插入点位于其中便可；
2) 单击“格式工具条”中“首行缩进”工具“ [image] ”，使其弹起即可，该工具是一开关式工具，再单击便使段落首行缩进；

有时两个字符的缩进量并不能满足您的要求，这时可以进行调整：

1) 选定要改变缩进量的段落，如果只是一个段落，那么只要使插入点位于其中便可；
2) 单击鼠标右键，从弹出的快捷菜单中选择“段落”命令，弹出一对话框如图4—8所示；

3) 在该对话框的下边可看到首行缩进选项，可以改变缩进量以及缩进单位，设置好后，单击“确定”按钮即可。

上级目录

系统目录


复制文本

段落对齐


使用

我们在使用字处理软件时，有一种很常用的功能，就是对齐，例如：普通的段落应该是左对齐，大标题应该居中，签名或日期应该靠右；有时还需要将多行内不同的字数的文字两边对齐。办公之星中提供了很多对齐功能，以帮助您设置不同的对齐方式。

利用工具条上的按钮可设置段落的对齐方式

a) 选定要设置对齐方式的段落；
b) 单击“格式工具条”中不同的按钮就可设置不同的对齐方式。

在工具条上有五个按钮，代表不同的对齐方式：

u * 左对齐：同一段内每一行都左对齐；
u * 中间对齐：每一行都居中显示，常用于标题；
u * 右对齐：常用于文章结尾的签名、时间日期或表格内的数字；
u * 两端对齐：同一段内，除最后一行外，每一行两端都对齐，在文章正文中时常采用这种方式，如图1所示就是几种对齐方式的示意图；

u [image] 全匀齐：同一段内，分别以左边界与右边界为边界，每一行的两端都对齐，如果最后一行缺字，将在每个字的中间均匀插入空隙，使每一行的左右边界都对齐，如下图2所示：

利用对话框设置对齐方式

在“段落”对话框中也有与段落对齐有关的选项。选定要改变对齐方式的段落后，单击“格式”菜单中的“段落”命令（或单击右键，从弹出的快捷菜单中选取“段落”命令），进入一对话框，对话框的上面有二组选项：一组称为“水平对齐”，它包含五个单选项，就是前面介绍的五种对齐方式；另一组称为“垂直对齐”，它包含三种对齐方式：居上、居中、居下。如果是正常的文本，这几种方式看不出差别，但如果将文字放在表格中，就会体现现这三种对齐方式的区别。

上级目录

系统目录


改变字体


使用

使用“字体组合框”改变字体

●选定要改变字体的文字；

●单击“格式”工具栏上的“字体组合框”下拉按钮，出现字体菜单；

●从字体列表中单击所需要的字体；

●用鼠标指针单击文档的其他位置，以取消反白显示选中的文本。

使用“字体”命令改变字体

●先选定需要改变字体的文本内容;

●单击“格式”菜单中的“字体”命令，出现如下图所示的对话框;

在该对话框中，单击“字体”下拉按钮，然后从下拉列表中选择所需的中文字体。这时可以从对话框下方的“字样”窗口看到字体的变化。

●单击“确定”按钮，即可将选中的文本改为刚刚设置的字体。

上级目录

系统目录


改变字号


使用

使用“字号”框改变字号

● 单击“格式工具”条中的“字号”框下拉按钮，出现“字号”下拉菜单列表。如果在屏幕上看不到“格式工具”条，请单击“视图”菜单中的“工具条”子菜单把它显示出来；

● 从“字号”下拉菜单列表中选择所需要的字号，在字号边这时会出现一预览小方框，可以看到改变字号后的效果；

● 用鼠标单击文档的其他位置，取消反白显示，将发现文字的字号已经发生了变化。

另外，在“字号”选项框中可直接输入您所需要的字的大小，以实现一些没有列出的字号以及特大字号，例如1000磅，输完后，直接回车即可。

通过“字体”命令改变字号

● 单击“格式”菜单中的“字体”命令，出现设置字体对话框。

● 在"字体对话框"中的“字号”选项中进行选择，然后单击“确定”按钮即可改变字体的大小。

使用工具条上的放大缩小按钮

在办公之星的格式工具条上有两个按钮，单击“减小字号”按钮“ [image] ”，选定文字将减少一个字号，最小为5磅字；单击“增大字号”按钮“ [image] ”，选定文字将增大一个字号，最大为168磅。

上级目录

系统目录


改变字型


选择要更改的文字

“字型”的一般指“扁体字”、“长体字”。具体来说，字型可分为标准型、长型、扁型和自定义型四种。

选择要更改的文字，或者在新格式开始的位置设置插入点。从“格式”菜单中选择“字体…”命令，在弹出的对话框中选择下列某一操作：

u 如果要设置长型字，选择“长型”单选框；

u 如果要设置扁型字，选择“扁型”单选框；

u 如果要选择自定义型，请在“长宽比”框中输入长与宽的比例。

长宽比的范围从30% ~ 300%，上图中显示的就是不同长宽比的字体。用户可以根据自己的需要设置不同的长宽比。

上级目录

系统目录


设置字体颜色


使用

使用“字体”命令设置字体颜色

⑴ 选定要设置颜色的文字，或者在新颜色开始的位置设置插入点；

⑵ 单击“格式”菜单中的“字体”命令，打开一对话框；

⑶ 单击对话框中“颜色”的下拉按钮，出现颜色列表；

⑷ 选择一种颜色；

⑸ 单击“确定”按钮。

使用“文字颜色”按钮设置颜色

⑴ 选定要设置颜色的文字，或者在新颜色开始的位置设置插入点；

⑵ 单击“格式工具”条上“文字颜色”按钮“ [image] ”，出现如下图所示的对话框，在“基本颜色”中已经有48种颜色可供使用，如果这些颜色还不符合要求，可以单击“定义用户颜色”按钮，立即出现右边的“增加用户颜色”选择框，可以利用光标配置自己需要的各种颜色；

⑶ 单击“确定”按钮即可改变文字的颜色。

上级目录

系统目录


改变字型

设置斜体、粗体、删除线


选择要更改的文字

设置粗体格式

如想将“深圳智岛软件开发部”九个字设置为粗体字，首先选中这几个字，然后单击“格式工具”条上的“粗体”按钮。这时，“粗体”按钮处于按下状态，那几个字变成“深圳智岛软件开发部”。如果想取消粗体字设置，只要重新选定这几个字，再单击“粗体”按钮，使其恢复原来的状态。

设置斜体格式

将“深圳宝安三十七区翻身路常富楼二单元303室”几个字设置为“斜体字”，操作步骤如下：

⑴ 选定“深圳宝安三十七区翻身路常富楼二单元303室”这几个字；
 ⑵ 单击“格式工具”条上的“斜体”按钮，就可以把选中的文本设置为斜体字，如下图所示；

⑶ 如果想取消斜体字设置，只需重新选定这几个字，再单击“斜体”按钮使其恢复原状。

设置删除线

⑴ 选定要设置删除线的文字；
 ⑵ 单击“格式”菜单中的“字体”命令，弹出“字体”对话框；
 ⑶ 选定“效果”这一组内的“删除线”选项；
 ⑷ 单击“确定”按钮，即可为这几个字设置删除线。

选定已设置删除线的文字，重复上述步骤，就可取消删除线。

上级目录

系统目录


改变字型

添加下划线、字符底纹、上、下角标及超级链接


选择要更改的文字

添加下划线

如果想为文件中的文字添加下划线，则首先选中这些文字，然后单击“格式工具”条中的“下划线”按钮“ [image] ”，就可以给选中的文本添加下划线，选定文本之后，按组合键 Ctrl + U 也可以设置下划线，重复上述步骤，可取消已设置的下划线。

添加底纹

底纹是文字下面的背景颜色，它随着被设置底纹的文字的增减而增减。
a) 选中欲设置的文字；
b) 单击“格式工具条”中“字符底纹”按钮。

设置上下角标

办公之星可以在编辑状态设置上下角标，能够打印出象X 2 、X 1 这样的符号。设置的具体步骤是：

a) 选中要设置成上下角标的文字；
b) 单击“格式”菜单中的“字体”命令，再在出现的对话框中单击“上标”或“下标”选项；
c) 单击“确定”按钮。

设置超级链接

如果通过显示链接地址的文字能直接链接到目的地，那无疑比较方便。办公之星中可通过一个自动指令实现，以下是具体操作步骤：

1) 选中要做链接的文字，例如“http://www.standsoft.com”，使其反显；
2) 单击鼠标右键，从弹出的快捷菜单中选择“设置自动指令”选项；
3) 在弹出的“自动指令”设置对话框中，选择常用自动指令中的“HomePage()”指令，在其括号内输入要链接的网址http://www.standsoft.com，单击“确定”返回即可；

如要删除或者修改文字链接的链接指向，重复上述操作，不选择任何指令重接“确定”返回或改变“HomePage()”指令括号中链接网址。

上级目录

系统目录


改变字型

字体修饰


选择要更改的文字

在办公之星中有有五种字体修饰功能，在一个字上只能设置一种修饰效果。

空心字

1) 选定要设置为空心字的文本，如果要把整篇文章都设置为空心字，可单击“编辑”菜单中的“全选”命令；
2) 单击“格式”菜单中“文字修饰”命令，出现一个子菜单，从中选择“空心”命令，就可把选中的文本改为空心字。如单击右键，从快捷菜单中选取“修饰>其他修饰>空心”也可实现。

阴影

阴影就是光线照射物体时产生的影子。办公之星中阴影是在文字的后面用灰色的颜色重新显示一遍。

立体

立体效果与阴影有一些类似，在办公之星中立体效果的颜色与文字颜色相同。

阴文与阳文

阴文与阳文是两种相对的效果，阴文凹进去的，阳文是凸出来的。在设置这两种效果时，设置的步骤与前面的完全相同。在办公之星关于它们有分别有两项可供选择：阴文1、阴文2和阳文1、阳文2。1和2之间的区别是一种阴影处颜色为灰色，另一种为黑色。

上级目录

系统目录


创建表格


利用插入表格按钮创建

单击“常用工具条”中“插入表格”按钮“ [image] ”，弹出一对话框如下图所示，用鼠标拖过对话框中方格，拖过的表格呈蓝色显示，同时在下面“定制”字样旁边以“行数＊列数”的形式显示。选择好以后单击鼠标左键即可在当前光标所在处插入一系统自定义好行、列宽的表格。

利用表格菜单创建

单击“表格”菜单，从中选择“插入表格”选项后,弹出一子菜单,从中选择“插入工作表”，将弹出一对话框如下图示。在“行数”，“列数”中输入您所需的数目后按确定后在当前光标所在处便按要求生成您所需要的表格。在列宽中可以定制表格的列宽。

系统目录


设置表元属性


设置表元内字符的属性

每个表元相当于一个文字框。用鼠标右键单击一个表元，从弹出的快捷菜单中选择“表元属性…”命令，将见到“表元属性”对话框，该对话框有三个有关字符属性的选项卡。

◆“数字格式”选项卡：可设置选定表元内数字的不同格式：常规、数值、货币、会计专用、百分比、特殊等格式。

◆“字体设置”选项卡：可设置选定表元中字体、字号、文字颜色、字型、字体效果等属性。

◆“字符对齐”选项卡：可设置选定表元的行间距、内间距，也可设置文字的水平对齐方式与垂直对齐方式。

设置表元的外观属性

选择“表元属性”对话框中选择“外观”选项卡，可从以下几个方面进行设置：

◆边框位置：可设定表元中边框线的有无以及一些斜线的有无等.

◆线型：缺省情况下，表元边线是实线，在“线型”框中有八种边线类型，可根据不同的需要设置不同的边线。

◆颜色：颜色是指边线的颜色，单击“颜色”旁边的下拉按钮，将４８种颜色可供选择，如还需更多，可通过“其它颜色”选择。

设置填充属性

选择“表元属性”对话框中选择“表元填充”选项卡，在这一选项卡中可设置表元的底色与底纹。系统提供了六种不同类型的底纹，此外还可选择底纹的颜色。如果觉得现有的底纹与底色都不能满足需要，还可设置底图。

系统目录


创建表格

斜线表元


利用插入表格按钮创建

通常将表格左上角的第一单元设置为斜线表元，用以表示表格中其他单元中的内容。

1) 用鼠标左键单击一下表格中要创建斜线的表元，将插入点移动到该表元；

2) 单击“表格工具条”上的“斜线表元”按钮“ [image] ”，弹出如下图所示的“创建斜线表元”对话框。

3) 这个对话框中有１５种不同类型的斜线表元，单击一种类型即可。如果要删除斜线，此时再单击这种类型。

4) 双击斜线表元，在光标处输入文字，设置好相应格式后，在表格内其它位置处单击。

5) 再次选中将才输入的文字，此时文字四个角上出现四个小黑块，将鼠标移至文字上拖动，可移动文字在表格内的位置。在右边中点处有一绿色小圆点，将鼠标移向它拖动，可对文字进行旋转。

系统目录


数据排序


在对表格数据进行处理时

在对表格数据进行处理时，会经常使用到数据的排序。在“办公之星”里，数据的排序有两种方式，即升序（递增）和降序（递减）。

◆选中表格，单击主菜单栏“数据＞排序”，弹出如图一所示的对话框，系统要求指定排序的条件，即“主要关键字”条件框、排序类型（数字和字符）、排序方向（行或列）和排序方式：“递增”或“递减”。

◆单击“选项”，弹出排序类型和排序方向对话框如下图:

◆比如：我们要对学生的成绩表进行排序，假如排序的条件是按“总成绩”的数据从高到低（递减）的顺序来排列的话；那么首先选中所有学生的总成绩，然后在“主要关键字”条件框里输入“总成绩”，在旁边的排序方式选择栏里选定“递减”；在“选项”一栏里选定“数字”和“按行排序”，最后点击“确定”按钮，那么学生的成绩表将会按“总成绩”从高到低顺序排列。

重要说明：在排序对话框里，还有一个“次要关键字”条件框和“第三关键字”条件框，所谓的“次要关键字”是指在满足“主要关键字”的条件下，必须遵循“次要关键字”的条件进行排序，而“第三关键字”是指在满足前两个条件的情况下，再次遵循的一个条件，采取这多层次的条件满足，可以使表格的数据排序更为清晰、明了。比如：在上面的例子里，如果当甲和乙的总成绩相同时，这时将谁排在前面呢？那么，我们就可以为排序确定一个次要条件（次要关键字），如：“语文”；那么这次排序将会在“总成绩”从高到低的顺序排序前提下，把“总成绩”相同的学生的“语文”成绩再从高到低的顺序排列一下；假如不幸的是，甲与乙的总成绩相同，语文成绩也相同的情况下，那么就有必要为他们的排序确定第三个须遵循的条件了，如“数学”，那么系统将会在满足前两个条件的前提下，又以“数学”成绩的高低为条件再排序一次。

上级目录

系统目录


定位单元格


使用鼠标定位

将鼠标指到所需定们的单元格上，并单击鼠标左键即可。

使用键盘定位

需先将表格选定后，再使用如下表方式：

击键名 | 功能 | 击键名 | 功能
← | 左移一个单元格 | ↑ | 上移一个单元格
→ | 右移一个单元格 | ↓ | 下移一个单元格
Ctrl + Home | 移至当前表格的A1单元格 | Ctrl+End | 移至当前表格的最后单元格

上级目录

系统目录


编辑和消除单元格数据


编辑单元格数据

选定要进行编辑的单元格,直接输入数据.如果选定的单元格中原来有数据,则新的数据加在原来数据的前面.双击单元格,则单元格内数据被激活,此时可直接在单元格内部对数据进行编辑.但如果单元格设定为“保护”的话，此方法无效。

“保护”单元格

● 选定要操作的表元；

● 单击鼠标右键，弹出一快捷菜单，从中选择“保护”选项即可。

取消编辑

单击常用工具栏中的撤消按钮“ [image] ”或从“编辑”菜单中选择“撤消”选项来进行恢复。

消除单元格数据

当您在编辑过程中想取消某些错误的输入时，可以使用“删除”命令：

● 选定需要清除的一个或多个单元格；

● 单击“编辑”菜单，将鼠标移至“删除”选项，或直接按 Del 键即可。

上级目录

系统目录


改变行高和列宽


改变行高

⑴ 首先双击表格，使表格处于编辑状态。

⑵ 将鼠标指针移动到要改变高度的那一行的下边线，当鼠标指针变成“ [image] ”时，按下鼠标左键，开始上下拖动鼠标指针,如下图所示。

⑶ 拖动时，有一直线跟随着鼠标移动，它显示出这一行改变后的实际高度，松开鼠标左键，行高就改变了。

上述介绍的方法并不太精确，如果要精确地调整行高可通过“格式”菜单来进行。在“格式”菜单中选择“行高”命令，此时弹出一对话框如右图所示。在数字框内可直接输入您所希望的行高值，另外也可通过数字框旁边的按钮“ [image] ”以０.１毫米为单位步增或步减调整。

改变列宽

⑴ 首先双击表格，使表格处于编辑状态。

⑵ 将鼠标指针移动到要改变度的那一列的右边线，当鼠标指针变成“ [image] ”时，按下鼠标左键，开始左右拖动鼠标指针。

⑶ 拖动时，有一直线跟随着鼠标移动，它显示出这一列改变后的实际宽度，松开鼠标左键，列宽就改变了。

另外，列宽也有精确的调整方法，同行高调整差不多。

上级目录

系统目录


增加

增加、删除行与列


New Page 3

增加行

◆通过Tab键：将表格切换到编辑状态，当光标在表格的最后一个表元时，按 Tab 键，就可自动增加一行。新增加一行的样式与原来最后一行相同。

◆通过“表格工具条”上命令：首先双击表格，将表格切换到编辑状态，单击“前插一行”按钮“ [image] ” ,在当前选定行之前插入一行;单击“后插一行”按钮“ [image] ” ,在当前选行之后插入一行 。

◆通过菜单

⑴ 选定要插入行的位置；
⑵ 单击“表格”菜单，然后单击插入行选项。在“表格”菜单中有二个有关的选项:“前插一行”、“后插一行”。顾名思义，就是在当前表元所在行前面或后面插入一行。

插入列

◆通过“表格工具条”上命令：插入列的步骤与插入行基本相同，双击表格，将表格切换到编辑状态，单击“前插一列”按钮“ [image] ” , 在当前选定列之前插入一列;单击“后插一列”按钮“ [image] ” ,在当前选列之后插入一列。

◆通过菜单

⑴ 选定要插入列的位置；
⑵ 单击“表格”菜单，然后单击插入列选项。在“表格”菜单中有二个有关的选项:“前插一列”、“后插一行”。顾名思义，就是在当前表元所在处前面或后面插入一列。

删除行、列

◆双击表格，将表格切换到编辑状态，然后将鼠标移动到要删除的行或列的表元中，单击“表格”菜单，在弹出的菜单中选择或“删除当前列”选项即可。

◆单击“表格工具条”上的“删除当前行” 按钮“ [image] ”,可删除所在行; 单击“删除当前列” 按钮“ [image] ” 可删除所在列。

上级目录

系统目录


表元的合并


合并表元

⑴ 双击表格，使之处于编辑状态。

⑵ 选定要合并的所有表元。

⑶ 单击“表格”菜单，在弹出的菜单中选择或“合并表元”命令，或单击“表格工具栏”上的“合并表元”按钮“ [image] ”。

⑷ 这些相邻的表元就合并成一个表元。

合并行或列

采用上述步骤，选定一行或一列，再进行合并，就可将一行或一列合并成一个表元。

上级目录

系统目录


表元批注


插入表元批注

选定表元（只能是一个表元），单击鼠标右键，弹出一菜单，选择“插入批注”选项，或者选择主菜单“插入>插入表元批注”，弹出一对话框，在文字框中输入注解，按“确定”按钮，此时，在选定的表元的右上角出现一小小的红色三角形符号，表示该表元已被批注，只要将鼠标在该表元内停留2秒，即会自动弹出批注框。

编辑表元批注

用右键单击含有批注的表元，弹出一菜单，选择“编辑批注”，弹出批注框，在文字框中编辑批注，完成后按“确定”按钮。

删除表元批注

用右键单击含有批注的表元，弹出一菜单，从菜单中选择“删除批注”，即可删除表元批注。

上级目录

系统目录


表元的位置引用


当进行表格计算时

当进行表格计算时，表元公式要用到其它表元的数值，在办公之星的表格里，可以用以下的位置引用取得其它表元的数值：

[工作表名称@表格名称@表元的行列标识]

例如，要引用 sheet1工作表的第二个表格的B5表元，则其位置引用为：[Sheet1@Tab2@B5]；当引用的表元在同一个工作表内，则表元位置引用可以不包含工作表名称，如引用同一工作表的第三个表格的D3表元，则其位置引用可表示为：[Tab3@D3]；当引用的表元在同一个表格时，则表元位置引用可以不包含工作表名称和表格名称，并且不需要中括号，如引用同一个表格的A6表元，则其位置引用直接为A6 。

上级目录

系统目录


自定义公式


输入公式

１、首先双击表格，将其转到编辑状态；

２、然后用鼠标单击要插入公式的表元，从“数据”菜单中选择“输入公式”命令，弹出一对话框如图７－１所示。或者单击“表格工具条”中“ [image] ”按钮也可以弹出此对话框。

图７－１ 输入自定义计算公式

在图中的白色方框是公式编辑区，单击要计算的表元，则对应的名称就显示在此区域中，再输入相应的计算符号。例如：我们要将表格中第二行第二列减去第三列，将计算结果保存在第一行第五列。则可按以下步骤进行：

１） 选定第一行第五列表元后，再打开“计算公式”对话框，并将“计算公式”对话框移动到表格的上方。

２）单击第二行第二列这个表元，在公式框中就显示出“Ｂ２”。

３）单击减号按钮“ [image] ”，公式框中变成“Ｂ２－”。

４）单击第二行第三列的表元，公式框中的内容为“Ｂ２－Ｃ２”。

５）单击“应用”按钮，在第一行第五列中就显示出计算结果。

６）单击“关闭”按钮。

在公式编辑区下面有十一个按钮，除了加、减、乘、除、小括号、中括号外，还有三个符号：“：”、“ @ ”、“ ，”。

◆符号“：”：连续计算，即当对多个相邻表元进行相同的运算时，可以用 “：”缩写公式。例如把第四行的四个表元连加时，可以在运算栏中输入Sum(Ａ４:Ｄ４)，则自动计算出正确的结果。

◆符号“@ ”：只有在表格运算涉及到跨表格、跨工作表计算时才涉及到。其格式是：[工作表名称@表格名称@表元]。具体可参见第一节。

◆符号“，”：用于公式计算中的函数有二个参数的情况下，用“，”将这两个参数隔开。

除了借助“表元输入对话框”输入对话框外，在表元内可直接输入公式。与在对话框中输入公式的形式一致。需要说明的是此时在公式前必须输入“＝”号，否则会将输入的内容直接作为表元的内容。

修改公式

在表元内输入公式之后，就无法采用常规的方法来修改这个表元中的内容。如果要修改已经输入的公式，首先双击表格，将其切换到编辑状态，单击要修改公式的表元，然后采用与输入一样的方式，对已经输入的公式进行修改。

上级目录

系统目录


自动计算


在办公之星中将一些简单算式定义为自动计算功能

在办公之星中将一些简单算式定义为自动计算功能，只需选定相应的表元，然后再单击这些命令，就可实现自动计算。

现假定我们要将表元的第二行第二列加上第三列，将结果保存在第四列中，操作步骤是：

⑴ 单击表格，将其转换到编辑状态。

⑵ 首先选定需要进行计算的表元。即同时选定第二、三列。

⑶ 然后在“数据”菜单中选择“纵横计算”这一项，又弹出一个子菜单，从子菜单中选择“横向求和”命令。或者单击“表格工具条”中“数据处理”按钮“ [image] ”，在弹出一子菜单中选取横向求和按钮“ [image] ”。

⑷ 在表格中第四列中的表元可得到计算结果。

如果有几列表元要进行相同的公式计算，例如第二列中所有数据和第三列所有数据有某种计算关系，并都将结果存放在第四列，或者第五列中，则可将第二、三列中数据全部选中，再按上述步骤进行即可。

另外需要注意的是：

● 如果使用横向计算，所有计算结果都存放在最右边的表元内，无法任意定位。

● 如果使用纵向计算，所有的计算结果都要存放在最后一行，也无法实现任意定位。

● 算式比较简单，只有几种加减乘除或求和、求平均值等运算。

上级目录

系统目录


填充公式


在进行一组排列在一起而计算公式又相同的表元计算时

在进行一组排列在一起而计算公式又相同的表元计算时，还有一种更为简捷的计算方法，那就是填充表公式。例如我们将A1至G1的数据连加后存入H1，A2至G2的数据连加后存入H2，这样一直到A10至G10的数据连加后存入H10，具体操作步骤如下：

◆选定A1至G1表元，通过自动计算功能中的横向边加功能求得和存入H1；

◆选定H1至H10表元，按住Ctrl的同时，按Enter键即可。此时H2表元内容即是A2至G10表元内容的和……H10即是A10至G10表元的和。

上级目录

系统目录


跨表格计算


如要将表格Tab1中A1的值与Tab2中B3的值相乘后放入表格Tab1的A2表元中

如要将表格Tab1中A1的值与Tab2中B3的值相乘后放入表格Tab1的A2表元中。步骤如下：

◆ 单击表格Tab1，将其转换到编辑状态。

◆ 选定要存放结果的表元A2，打开计算公式对话框。

◆ 单击第一行第一列这个表元，在公式框中就显示出“Ａ１”。

◆ 单击乘号按钮“ [image] ”，公式框中变成“Ａ１* ”。

◆ 单击表格Tab2中第三行第二列的表元，公式框中的内容为“Ａ１*[TAB2@B3]”。

◆ 单击“应用”按钮，在表格Tab1中表元A2就显示出计算结果。

◆ 单击“关闭”按钮。

上级目录

系统目录


跨工作表计算


现假设要将工作表Sheet1中表格Tab1中A1的值与工作表Sheet2中Tab2中B3的值相乘后放入表格Tab1的A2表元中

现假设要将工作表Sheet1中表格Tab1中A1的值与工作表Sheet2中Tab2中B3的值相乘后放入表格Tab1的A2表元中,步骤如下：

◆单击表格Tab1，将其转换到编辑状态。

◆选定要存放结果的表元A2，打开计算公式对话框。

◆单击第一行第一列这个表元，在公式框中就显示出“Ａ１”。

◆单击乘号按钮“ [image] ”，公式框中变成“Ａ１* ”。

◆将工作表切换到工作表Sheet2中，单击表格Tab2中第三行第二列的表元，公式框中的内容为“A1*[SHEET2@TAB2@B3]”。

◆单击“应用”按钮，在工作表Sheet1的表格Tab1中表元A2就显示出计算结果。

◆单击“关闭”按钮。

上级目录

系统目录


灌入数据


利用数据灌入功能可以调入外部的数据

利用数据灌入功能可以调入外部的数据，这对于表格数据的更新有着非常重要的作用。灌入数据的步骤是：

● “选择数据源 -> 指定数据库 -> 指定数据文件 -> 灌入数据”。

● 单击主菜单栏“数据>灌入数据...”，系统弹出如下图对话框：

● 选择数据源----单击上图的“选择数据源”按钮，弹出如下图对话框。指定要灌入的文件数据源，系统给出了五种数据源。要搜索数据源，在搜索对话框中输入搜索条件，要指定另外的数据源，单击“新建”。

● 指定数据库----指定数据源后，单击“确定”按钮，系统弹出如下图对话框。

● 单击“数据库”按钮，指定要登录的数据库。系统又弹出如下图对话框：

● 指定数据文件的正确路径和文件名，单击“确定”按钮，系统将该数据文件的内容显示在对话框里（如下图）。选择数据表(数据表项目），单击灌入数据，选定的数据就被灌入到当前工作表中了。

说明：当选定了当前工作表中的表格时，选定的数据就被灌入到当前工作表所选定的表格中；当没有选定表格时，系统将会在当前工作表的页面自动生成以选定的数据为表元的表格。

上级目录

系统目录


自定义公式

函数介绍


输入公式

对函数的理解

我们在用公式进行计算时，有时会遇到这样一种情况我们想要进行某种计算，而我们却无法直接编写公式，这时就要用到我们现在要介绍的办公之星中的内置公式——函数。

在办公之星中函数是预定义的内置公式，它使用被称为参数的特定数值，按照自己语法的特定顺序进行计算。

函数的参数可以是数字、文本形式、或单元格引用。给定的参数必须能产生有效数值。另外，函数的参数还可以是常量公式或其他函数。

函数的语法以函数的名称开始，后面是左圆插号以及逗号隔开的参数和右圆括号。

函数的分类

办公之星中提供了许多非常实用的函数，我们将这些函数按功能分为以下几种类型：

u 数学和三角函数：使用数学和三角函数可以处理简单和复杂的数学计算；

u 统计函数：使用统计函数可以对数据区域进行统计分析；

u 日期函数：用于在公式中分析和处理日期值和时间值；

u 文本函数：文本函数用于在公式中处理文字串；

u 逻辑函数：使用逻辑函数可以进行真假值判断，或者进行复合检验。

有些函数比较的简单，并不需过多的描述。下面我们将一些较常用的进行介绍：

1)SUM函数

SUM函数用于计算单个或多个参数之和。

语法：

SUM（number1，number2，…）

number1，number2，…为1到30个需要求和的参数。

注意：在使用SUM函数时

I. 参数可以直接键入；

II. 如果参数是数值或单元格引用；

III. 当参数为错误值或为不能转换成数字的文本时，一律做为零处理。

例：SUM（3，2）等于5。

b) AVERAGE函数

AVERAGE函数是对所有参数进行算术平均值计算。

语法：

AVERAGE（number1，number2，…） number1，number2，…为要计算平均值的1~30个参数。参数应该为数值或单元格引用。

注意：

如果数值或单元格引用参数中有文字、逻辑值或空白单元格，则将其值视为零。

例：AVERAGE（10，3，2，30）等于11.25。

如果B1单元格其值为“3”，那么AVERAGE（B1，3，30）等于12。

c) DAY函数和CURDATE函数

DAY函数返回计算机系统内部时钟当前日期的天数。

语法：

DAY（）

CURDATE函数以类似于“2001/3/1”的形式返回计算机系统内部时钟的当前日期。

语法：

CURDATE（）

DAY函数和CURDATE函数所产生的结果是可变的，这二个函数不需要参数。

d) INT函数

INT函数用于返回实数舍入后的整数值。

语法：

INT（number）

Number是需要进行取整处理的实数。

例：INT（8.9）等于9。

INT（—8.4）等于—8。

e) LOG函数

LOG函数是返回一个以10为底数的对数，在数学计算中经常用到。

语法：

LOG（Number）

Number为计算对数的正实数。

例：LOG（10）等于1。

LOG（10^5）等于5。

f) DIGIT函数

返回指定数指定位数上的值。

语法：

DIGIT( num1, num2 )

num1： 指定数值；

num2： 指定位数，0指个位，1指10位，-1指10分位。

例：Digit( 4356, 2 ) = 3, 4356的百位等于3；

Digit( 43.56, -2 ) = 6, 43.56的百分位等于6。

g) IF函数

执行真假值判断，根据对指定条件进行逻辑判断的真假而返回不同的结果。

语法：

If（logical_test, value_if_true, value_if_false）

logical_test：判断条件

value_if_true：条件为真时的返回值；

value_if_false：条件为假时的返回值；

例：If（23>8, "asdf", 56 ） 等于 asdf；If（ 23<8, "asdf", 56 ） 等于56。

F3表元的值为99999，则IF(F3 < 10000, "", IF(F3 < 100000, "￥", DIGIT(F3,5) ))等于￥。

上级目录

系统目录


创建图表


图１ 创建图表对话框

◆ 单击表格，将其切换到编辑状态；

◆ 选定创建图表时要用到的表元。

◆ 从插入菜单中选取“图表…”命令，弹出一对话框，如下图示:

图１ 创建图表对话框

◆在对话框中有二个选项：在“创建方式”中选取数据的排列方式是“按行”或“按列”；在图表类型中有八种图表类型可供选取。

◆ 单击“确定”按钮，就可大体得到下图所示图表。

此外，创建图表还可以通过“常用工具条”中按钮“ [image] ”来进行。选定创建图表时要用到的表元后，单击此按钮，弹出如图７－７所示对话框。在此对话框中，以图表的形式更出了图表的类型。选择一种图形后，该图形凸出显示。且在对话框的下边用文字的形式说明了该对类型。在一般的情况下，系统默认为系统“创建方式”为行。如果要改变“创建方式”，选择对话框中图形“ [image] ”，此时又弹出图1所示对话框。其它设置与前面相同。

系统目录


编辑图表


首先选定此图表

首先选定此图表，使其切换到编辑状态。在图表中有几项基本组成元素，包括标题、标注、图表、图例这几部分，如下图示:

修改标题

实际上，标题就是一个文字框，单击标题，可修改标题内的文字。用鼠标右键单击标题，从弹出的菜单中选择“文字框属性”命令，可修改标题的字体、边框、填充、阴影等属性。

改变图表的属性

双击图表，使之进入编辑状态，然后单击一下中间的图表，在图表的周围出现八个操作点。将鼠标指针移动到操作点上，当指针改变形状后（如果鼠标指针在左右操作点上，指针变成“ [image] ”; 如果鼠标指针在上下操作点上，指针变成“ [image] ”； 如果将鼠标指针移动到右下角的操作点上，指针变成“ [image] ”,按下鼠标左键，拖动鼠标，在边框上就显示出图表的大小，如下图示:

如果选定图表之后，单击鼠标右键，从弹出的快捷菜单中选择“ 图表属性 ”命令，可改变刻度数据。在快捷菜单中选择“图表类型”命令，则可以改变图表的类型。

改变图例的属性

在图表的右边有图表的图例，即显示出不同数据系列的具体含义，例如在上图中，蓝色的矩形代表第一季度、红色的矩形代表第二季度、而绿色的则代表第三季度等。

在初始时，图例中这样矩形并没有说明文字，需要我们以后添加，其操作步骤是：

1) 选中要编辑的图表框，使之进入编辑状态。

2) 双击图例中文字，修改好改变的文字；

3) 单击鼠标右键，从弹出的快捷菜单中选择“字体”、“段落”、“修饰”等，可分别改变字体，段落间距、字体颜色、排列方式等。

图例其实也是一个文字框。

系统目录


绘制图形


图形的绘制过程大致相同

图形的绘制过程大致相同，这里以直线这种最简单的图形对象为例，讲解绘制图形的基本操作。

① 将“绘图工具”显示在桌面上，如果没有显示在桌面，单击“视图”菜单中“工具条”子菜单内的“绘图工具”即可；

② 单击工具条上的“直线”按钮“ [image] ”，鼠标指针变成了“ [image] ”；

③ 将鼠标指针移动到编辑区内，按下鼠标左键，这就是直线的起点；

④ 拖动鼠标，从起点到鼠标指针之间出现一条虚的直线，随着鼠标的拖动，这条虚线如同橡皮筋，可长可短，也可任意旋转，如图(a)所示。

⑤ 松开鼠标左键，在编辑区内就出现一条实直线，直线的两端有两个黑色小方框， 叫作操作点，如图(b)所示。通过操作点可以改变直线的长短、方向等。

系统目录


选定对象

选定图形对象


选定一个对象

将鼠标指针移动到图形上面，用鼠标左键单击一下，在图形对象的一些关键点上出现一些操作点，这样，就选定了一个对象，如果您要操作图形对象，首先应该选定对象。

选定多个对象

在单击图形对象之前按着键盘上的 Shift 键，可连续选定多个对象。如果要取消已选定的某个对象，在按着键盘上的 Shift 键的同时，单击一下已选定的对象即可。

选定多个对象还有一种简捷的方法，直接通过鼠标拖动。将鼠标放置到编辑区，移到要选定的对象的左上角，按下鼠标左键，向右下方拖动鼠标，从起始点开始形成一个虚框，如图(a)所示，随着鼠标指针的移动，虚框在变化，当将所要的对象都包含在虚框内后，松开鼠标左键，就会选定所有的对象，如图(b)所示。在通过鼠标选定的过程中，无论鼠标起点是在左上角、右上角还是左下角，只要能形成矩形选中图形对象即可。

系统目录


移动图形


New Page 2

◆选定图形对象,将鼠标指针移动到选定对象上;

◆当鼠标指针变成了“ [image] ”时，按下鼠标左键，鼠标指针变成了“ [image] ”，拖动鼠标，被选定的对象的虚线随着鼠标指针移动，如下图所示;

◆松开鼠标左键，所选对象就可移动到新位置上。

◆如果要移动多个选定对象，在选定对象后，将鼠标指针指向任何一个被选中的对象的实体上或操作点上，其余操作与单个对象移动相同。

系统目录


复制图形


New Page 2

通过剪贴板复制

◆选定要复制的对象，单击工具条上的“复制”按钮“ [image] ”（或按Ctrl + C键），在选定区域外单击一下鼠标，取消选定;

◆单击工具条上的“粘贴”按钮“ [image] ”（或按键盘上的 Ctrl + V键），复制的对象就出现在编辑区的左上角。

通过键盘复制

◆ 选定要复制的对象；

◆ 将鼠标指针移动到选定对象上，鼠标指针变成了“ [image] ”；

◆ 按着键盘上的 Ctrl 键，鼠标指针变成了“ [image] ”；

◆ 不要松开 Ctrl 键，拖动鼠标指针，将图形对象移动到合适的位置，松开鼠标，在新地方出现一个复制好的对象。

系统目录


改变图形大小


New Page 2

◆ 选定要改变大小的图形对象；

◆ 将鼠标指针移动到图形的操作点上，当鼠标指针发生变化时，按下鼠标左键拖动鼠标；

◆ 随着鼠标的拖动，在鼠标指针旁边显示出对象的大小，松开鼠标指针，对象的大小就变了；

◆ 将鼠标移动到不同的位置上，鼠标指针也不相同，例如：将鼠标移动到右下角的操作点上，鼠标指针变成了“ [image] ”，而移动到右边中点的操作点上，鼠标指针变成了“ [image] ”。

系统目录


对齐与排列


如果您绘制了多个对象

如果您绘制了多个对象，对象之间的位置很关键，特别要精确绘制一些图形时，如何快速对齐这些对象就很重要。对齐就是将所选对象按照某种标准进行排列，例如：按照对象的左边界对齐、右对齐等等，对齐的步骤是：

◆ 选定要对齐的多个对象；

◆ 在选定的对象上单击鼠标右键，单击快捷菜单中的“对齐”命令，出现一个子菜单，如下图示，选择不同的的对齐命令，可实现不同的对齐方式。

另外，在“对齐工具条”中还可以设置“对象等宽”、“等高”、“大小相等”、“对象水平/垂直间距相等”等。下面对它们分别进行介绍：

u 对象等宽：以较小的宽度为准，所有选中对象宽度相等；

u 对象等高：以较小的高度为准，所有选中对象高度相等；

u 大小相等：以较小的大小为准，所有选中对象宽度和高度相等；

u 水平间距相等：三个或三个以上对象间水平方向的距离相等；

u 垂直间距相等：三个或三个以上对象间垂直方向的距离相等；

系统目录


对齐与排列

对象的层次


如果您绘制了多个对象

图形对象之间可以相互重叠，因此，对象之间就有层次关系。选定一个对象之后，单击鼠标右键，从弹出的快捷菜单中单击“叠放次序”命令，可出现一个子菜单，如图1所示，里面有六个菜单项，选择不同的命令就可改变对象的层次。

图1 改变对象层次的快捷菜单

选定要改变层次的对象，然后从快捷菜单中选择“对象层次”中的命令，就可改变对象之间的层次。

u 置于顶层 将选定的对象提到所有对象的前面，即将此对象放在所有对象最上面，如图2(a)所示，就可将在最底层的文字框层（在办公之星环境下，每一个对象作为一层）提到所有对象的前面；

u 置于底层 将选定的对象置于所有对象的下面，文字层上；

u 上移一层 将选定的对象向上移动一层，如图2(a)中如果将矩形上移一层，就可位于椭圆的上面；

u 下移一层 将选定的对象向下移动一层；

u 浮于文字上方 一般情况下所有对象都浮于文字层的上方；

u 衬于文字下方 将选定对象置于文字层下。如对象被置于文字层下，直接选取是选取不了的。这时，需按住Alt键的同时，再进行选取。

图2 改变对象的层次

办公之星中除文字外，其余的都做为一个对象存在，每一个对象都占据着一个层。一般情况下，办公之星中各层分布情况下图所示：

系统目录


对齐与排列

组合与分解


如果您绘制了多个对象

组合

将多个对象组合成一个新的对象，无论对这个新对象实施何种操作，对象之间的相对位置关系都不会改变。组合之后，就无法针对其中的一个对象实施操作。

a) 选定要组合的多个对象，如下图a所示；

b) 在选定的图形对象上单击鼠标右键，从弹出的菜单中选择“组合”命令，就可得到上图b所示效果。

c) 这时再选定这个组合的对象，将只有一个选定框。

分解

将组合的对象拆开，还之以本来面目。

a) 选定要分解的组合对象；

b) 单击鼠标右键，从弹出的快捷菜单中选择“分解”这个命令。

系统目录


对齐与排列

排版与绕排


如果您绘制了多个对象

排版位置

指对象与文字之间的位置关系，即如果图形不在文字上浮动着，如何随着页面的改变而变化图形的位置。改变图形对象的排版位置方法：

选定一个或多个对象，然后单击鼠标右键，从弹出的快捷菜单中选择“对象随文”，弹出下一级菜单，里面有二个命令：“对象跟随文字”和“取消对象跟随”。（如下图所示）。

选中“对象跟随文字”后，对象将跟随当前文字位置的改变而改变其在页面中的位置。另外，这时“对象”可以象一个普通文字字符一样，改变它在文字中的相对位置。

文字绕排

在对象浮动的时候，可通过“文字绕排”设置改变对象与文字间的相对排版关系。

选定一个或多个对象，然后单击鼠标右键，从弹出的快捷菜单中选择“文字绕排”子菜单中的一个命令,如下图示:

u 取消绕排 对象和文字间位置各自保持独立；

u 两边绕排 文字围绕对象两边排列；

u 两边不绕排 对象所在行不允许有文字存在；

u 一边绕排 文字自适应对象在一边排列，另外一边不允许有文字；

u 左边绕排 文字绕着对象左边排列，右边不允许有文字；

u 右边绕排 文字绕着对象右边排列，右边不允许有文字。

在上图中红色星状物为一“四角星”图形对象，从图中我们看不出“一边绕排”与“右边绕排”的差别。一边绕排能根据对象所在文字两边文字的多寡自行决定是按照“左边绕排”还是“右边绕排”来进行设置。如对象左边文字少就“右边绕排”，反之则“左边绕排”。

系统目录


绘制按钮


New Page 3

◆单击“绘图工具条”上的图标“ [image] ”。如果没有此工具条，请单击“视图”菜单中的“工具条”选项，在弹出的子菜单中选择“绘图工具”选项。或者也可以单击“插入”菜单中的“控件”选项，在弹出的子菜单中选择“按钮”选项。

◆在文档空白处单击鼠标，然后拖动，在鼠标拖动处有一虚框，它显示着生成后按钮的大小。放开鼠标，则生成一按钮如下图示。按钮的周围有八个黑色小方框，叫做操作点，将鼠标移向它然后拖动可以改变按钮的大小。关于操作点的操作以前介绍过。同时光标在操作点中央闪烁，这时候可以输入按钮上的提示文字。

◆在光标闪烁处输入按钮提示文字后在文档空白处单击，一按钮就生成了。

系统目录


编辑按钮


改变大小

① 选中要操作的按钮，用鼠标单击，按钮周围出现黑色小方块的操作点。如果按钮已经设置了自动指令并且自动指令已经生了效，应该先使控件失效。其操作步骤是：在设置自动指令的按钮上单击右键，从弹出的对话框中选择“控件生效”选项。

② 将鼠标移向操作点，然后拖动到合适的大小。

③ 在文档空白处单击。如果是已经设置了自动指令的按钮应重新使控件生效。

移动和复制

首先选中要操作的按钮，将鼠标移向按钮等指针变为“ [image] ”时拖动。如果在移动的过程中同时按住“Ｃtrl ”键，那么将在移动的目的地复制一个按钮。对于复制操作也可以通过剪贴板进行，具体步骤可参见前面的介绍。

层次的改变以及对齐

按钮也是一个对象，因此也可以象其它对象一样设置它的层次以及对齐等。具体操作可参见前面其它的对象。需要注意的是，如果控件生效后的按钮这些操作都是无效的。要先使用控件生效。

按钮的属性

按钮不仅可以象其它对象一样移动、复制，还可以设置图案等属性。选中按钮后，单击鼠右键，在弹出的快捷菜单中，选择“控件属性”选项，弹出对话框如下图所示:

在该对话框“位置尺寸”选项卡中可精确设置按钮在整个文档中的位置。在“外观”选项卡中可设置底图，其具体过程以前有介绍。下图是一设置了图片的按钮。在“其它”选项卡里可以设置使按钮不被移动和不被打印。

系统目录


宏指令

自动指令


对于word中的宏功能想必大家都不会陌生

在办公之星中的自动指令类似编程语言里的函数，在设置一定的参数后一个指令便可实现一个特定的动作。在办公之星中，自动指令是和按钮这个控件连在一起使用的(自动指令也同样适用于页面文字）。设置自动指令的步骤是：

1)在“按钮”上单击右键，在弹出的快捷菜单中选择“设置自动指令…”选项，弹出一对话框如下图所示；

2)在对话框里的自动指令集里有二十一个自动指令供您选择，被选中的自动指令呈蓝色反显，同时在右边的自动指令描述框里显示出该自动指令的功能以及用途等一些情况的描述。自动指令由自动指令名和自动指令参数组成。双击选中的自动指令，则在自动指令参数设置框中便出现该自动指令，在自动指令参数中设置好参数，再单击确定。

3)在设置自动指令的按钮上单击右键，从弹出的对话框中选择“控件生效”选项，这样一个自动指令就设置好了。

设置好自动指令后，如果您单击按钮的话，您将发现按钮像我们平时使用的按钮一样，陷下去又弹上来，并执行了相关的自动指令操作。

以下是自动指令的列表

自动指令

功能

ActiveSheet(工作表名称)

击活工作表

AddNewSheet()

增加新的工作表

Beep()

使计算机发出嘟嘟声

CloseFile()

关闭当前文件

Email(邮件地址)

发送电子邮件。

如：Email(support@standsoft.com)

Exit()

退出系统

FullScreen()

全屏显示

GotoPage()

跳到指定页，如打开第六页GotoPage(6)

HomePage()

根据网址打开网页，如HomePage（http://www.standsoft.com)

NewFile()

新建文件

OpenFile(文件名)

打开文件

PageUp()

向前翻一页

PageDown()

向后翻一页

PageSetup()

此命令无参数，弹出页面设置对话框

PreView()

打印预览

Print()

打印当前文件

Save()

保存文件

Send File()

发送当前文件

SaveAs()

换名保存文件

WinExec(应用程序名称)

执行应用程序。说明：应用程序不在系统目录时，应用程序名称要包含应用程序所在目录。如：WinExec(c：\MyFile\MySoft.exe)


如何定制办公系统


下面将以制作深圳华为办公系统为例来讲解如何定制办公系统。

制作首页面

◆建立一个新文件，将文件名取为“华为办公系统”。在“页面设置”对话框中设置好页面的大小，在页面背景里选取一幅具有一定意义的画面，选择拉伸模式。这样的话，图片便能充满整个页面。设置后的效果如下图所示。为了能够看清整个页面，最好选择整页的浏览模式。

◆在页面的正上方输入一行文字“深圳华为技术办公系统”，设置好字体、大小、颜色。这就是整个系统的标题。

◆放入一个按钮，设置自动指令为“OpenFile()”。在这个自动指令的参数框里指定参数是要打开的文件名。在这里我们输入“公关管理.ost”，必须输入后缀。需要注意的是这个自动指令所能打开的文件必须与指令所在文件在同一个目录下。然后复制按钮，复制五个。分别在六个按钮上输入提示文字：“公关管理”、“事务管理”、“财务管理”、“生产管理”、“人事管理”、“反馈信息”。并将对应按钮里自动指令的参数，即要打开的文件名修改为与按钮提示文字一样。将按钮按次序拖放到靠左边合适位置对齐，最后使所有按钮控件生效。

◆在右下边再插入一个按钮，将按钮的提示文字设置为“退出系统”。其自动指令为“CloseFile()”。使按钮控件生效。最后生成的主页面如下图所示。

◆为了使生成的页面在以后的使用过程中不致于无意中被修改，可将整个页面保护起来，使其“只读”而不“可写”。其操作步骤如下：

1)从“工具”菜单中单击“保护”命令，从弹出的子菜单中选择“设置修改权限”命令，又弹出一对话框，如下图1所示。

图1－设置修改权限对话框

2)在“新密码”文字框里输入您的密码，在“确认新密码”文字框里再重新输入后，按确定即可。

如果有修改的必要，可撤消权限。依照上面步骤1）进行，这时候弹出对话框如上图所示。在“权限密码”文字框里输入您设置的密码，单击“确定”按钮后，弹出图1所示对话框。点击里面的“撤消权限”按钮即可。

制作“公关管理”文件

注意此文件必须与主页面在同一个目录下。此文件包括几个工作表，依次是：“公关管理”、“通信簿”、“工作日程”、“会议记录” 。注意第一个工作表一定要是“公关管理”，它是此文件的主界面。

1）“公关管理”工作表的制作

此工作表的制作与此系统主页面的制作大同小异。由于是在几个工作表之间切换，因此几个按钮的自动指令是“ActiveSheet()”。这个自动指令的功能就是击活工作表，它的参数是要击活的工作表的名称，没有后缀。“返回”按钮的自动指令是“CloseFile()”。不须设置参数。最后制作成的“公关管理”工作表如下图所示。

2）“通讯录”工作表的制作

此工作表的主要内容为一表格，关于表格的有关内容可参见前面。工作表里有几个按钮：“查找”、“打印”、“返回”。它们对应的自动指令分别为“Find()”、“Print()”、“ActiveSheet(公关管理)”。第一个自动指令的功能是打开查找对话框。“返回”是要返回到上一个页面，而上一个页面是“公关管理”，因此其自动指令为击活“公关管理”工作表。制作好后的工作表如下图示。

其他工作表以及系统中其他文件的制作大同小异，您可以参照办公之星中已经定制好的系统制作。

系统目录


页面设置


单击主菜单

单击主菜单“文件＞页面设置…”或将鼠标移到工作表任一位置单击鼠标右键，选择“页面设置…”，此时，弹出一对话框如下图：

◆ 纸张规格

每次打开一个空文档，缺省的纸张规格A4，它的具体尺寸为210X297毫米。单击“纸张规格”旁边的下拉列表框，可见到办公之星支持的所有纸张类型。单击一种纸张类型，在“宽”与“高”框中显示选定纸张类型的高度与宽度。也可以自己任意确定纸张的大小，这时需在纸张类型中选择“自定义”。 并不能随意指定纸张类型，用户指定的纸张类型必须与使用打印机兼容，否则在打印输出时极易出现错误。

◆ 纸张方向

可选择"纵向"与"横向"两个选项，改变选项之后，在“预览”框中就显示出改变之后的效果。

◆ 页面边距

一张纸上，上下左右留出来的空余宽度就是页面边距。用户可分别设置纸张四边的边距，缺省情况下，上下边距都是20毫米，左右边距都是15毫米。

◆ 页面背景

包括设置背景颜色色和图片，在设置图片的下拉列表框中包含了四个选项： 无、 居中、平铺、拉伸。当设置了背景图片欲取消时以及在切换背景图片时请选择“无”选项。

◆ 页面分栏

大多数情况下为二栏，最多可分为五栏。 可在“栏间距”中指定栏与栏间的间隔，缺省值为5毫米。

◆ 文字行线

在页面中绘制出一行行相互平行的水平线，可改变行线的颜色。行线间距会随页面文字的大小自行变化。

系统目录


打印机设置


单击主菜单

单击主菜单“文件＞打印…”命令，设置完打印参数后单击“确定”按钮后弹出打印对话框,如下图示：

单击“属性”按钮，设置打打印机参数，如设置打印分辨率、打印模式、打印色彩、打印纸规格等。不同的打印机，其驱动程序不同，设置的界面也不同，但基本的设置方法基本一致，这里就不多加说明。

系统目录


打印预览


打印预览功能

在“文件”菜单中单击“打印预览”命令，设置完打印参数后，单击“确定”按钮后弹出预览窗口如上图所示。如果单击工具栏上的“打印预览”按钮“ [image] ”，也可打开“打印预览”窗口。

打印预览屏幕

在预览窗口中系统默认每次将显示一整页，如果您改变预览窗口的大小，显示比例也随之变化。如果要改变打印预览的显示比例，将鼠标移到预览区，此时鼠标形状变为“放大镜形状”，按鼠标左键放大。另外可单击屏幕上“放大”和“缩小”按钮，来改变预览比例。您可以使用窗口中的水平和垂直的滚动条或光标、Pgup、PgDn键来移动页面。

当屏幕显示双页时，可单击“单页”按钮使它回到整版显示状态。当屏幕显示单页时，单击“双页”按钮使屏幕同时显示两页。

单击左上角的“退出”按钮，系统退出打印预览，回到编辑窗口。

打印预览时的打印输出

打印预览屏幕第一行上的功能按钮中有一个“打印”按钮，用鼠标单击这个按钮，系统弹出“打印”对话框，可以将当前文档打印输出。

系统目录


页面设置

页眉与页脚


单击主菜单

页眉是出现在每页顶部的文字或图案；而页脚出现在页面底部。页眉和页脚中可包含章节标题、公司或企业标志。

◆ 插入页眉或页脚

1）在“插入”菜单中选择“页眉…”或“页脚…”命令；

2）此时光标自动出现在“页眉…”或“页脚…”处，如下图所示，直接输入页眉页脚；

◆ 删除或修改页眉页脚

在页面顶端或底部的页眉和页脚虚框中可直接删除或修改页眉页脚。

文档中每一页的页眉页脚都是相同的，在任意页面上直接修改页眉与页脚的内容，系统将自动修改每一页。

◆ 在页眉页脚中插入日期

1） 单击页眉框或页脚框，进入页眉或页脚。

2） 单击“插入”菜单中的“日期和时间”命令，将见到下图所示的对话框。

3） 在此对话框中，可以分别插入时间、日期或星期。共有十四种格式可供选择。

◆ 设置页眉页脚的位置与大小

1） 单击“文件”菜单中的“页面设置”命令；或在文档的空白处单击鼠标右键，在弹出的 快捷菜单中选择“页面设置…”选项，出现一对话框；

2） 在页眉和页脚“距边界”框中输入页眉距顶边和页脚距底边的距离；

3） 单击“确定”按钮。

其实页眉和页脚本身就是一个文字框，只是位置的不同。因此对于文字框的所有操作都适用于页眉和页脚，这给我们带来了极大的方便。

系统目录


页面设置

打印参数设置


单击主菜单

无论是在预览还是要打印时首先会弹出“打印参数设置”对话框如下图所示：

u 打印选中对象：在预览及打印中只显示、输出选中对象的内容；

u 单色打印：不管您打印的内容的颜色是彩色的还是单色的都以黑白的形式打印；

u 打印页面背景：连同页面背景也作为打印的内容；

u 反片打印：将打印内容镜像后打印输出；

u 打印比例：它是打印输出幅面大小和页面设置幅面大小的比值，您可以根据页面设置中幅面的大小和最后打印时页面的幅面调节相应的比例，从而输出满意的打印效果。

u 平铺打印：主要用于名片之类的打印。它会根据页面幅面大小及打印纸设置幅面大小决定打印内容在打印纸幅面上的排版数量及位置。在这种情况下，页面幅面大小一般要比打印纸设置幅面大小要小二倍以上，否则根本体现不出效果。例如：在用办公之星设置名片时，页面幅面只须设置为实际名片大小即可。

将该选项选中后，会弹出一对话框如下图所示：

里面可以对打印内容间的空白间隔大小及是否打印间隔标志进行设置。

u 按纸型缩放：则不管文件中页面设置的大小，而只根据所选打印纸幅面的大小输出文件。

u 特大页面打印：通过它可对页面进行放大打印及分割打印，对于我们打印海报或其它宣传资料无疑是极为有用处的。

此时又弹出一对话框如下图所示，里面有三个单选项，有三个按钮，下面对它们的作用分别进行介绍：

Ø 将一页内容横向扩为XX页打印：以此时系统打印机页面或屏幕设置页面大小为基准横向扩大XX倍后打印或预览输出，放大后原幅面长宽比不变；

Ø 将一页内容纵向扩为XX页打印：与上同，将方向改为纵向即可；

Ø 指定打印比例为XX：指定整个幅面的缩放比例；

Ø 选项：指定上述三个单选项扩张打印页面基准。有二项供选择：打印纸页大小、屏幕页面大小。

u 设置打印机：在办公之星中页面设置与打印机设置需分别进行设置，打印机默认页面规格为A4，改变打印机设置会引起打印预览及打印输出的变化。单击此按钮，弹出如下图所示对话框。在此对话框中可对打印机属性以及打印纸张页面大小、方向进行设置。

系统目录


绘制按钮

图像与图像编辑


New Page 3

插入图像

我们在前面介绍过如何在文档中绘制各种图形，但图形只能是一些线条或文字。如何在文件中插入照片、通过扫描仪输入的图像或其他以图像格式保存的文件呢？

1) 单击“插入”菜单中的“图片”命令，屏幕上出现下图所示的对话框：

2) 在“搜寻”框中找到图像文件的保存位置,单击在列表框中显示出的图像文件，在下面的“文件名”中就显示出该文件的文件名；
3) 最后单击“确定”按钮，就可将图像插入到文件中。

图像的位置

将图像插入到文档中之后，就成为一个独立的对象，我们在以前介绍的关于对象的操作都可应用于图像对象。

例如，用鼠标右键单击图像，弹出的快捷菜单与前面介绍过的快捷菜单相同，单击“叠放次序”命令，从出现的子菜单中可见到以前介绍过的“置于顶层”、“置于底层” 、“上移一层”、“下移一层”、“浮于文字上方”、“浮于文字下方”六个选项。

图像的对齐

首先选定多个对象，可以是图形与对象，也可以是多个图像，然后用鼠标右键单击选定的图像，从弹出的快捷菜单中可选择“对齐”选项，从又弹出的子菜单中可选择不同的对齐方式，每一种对齐方式的具体含义以前都介绍过，在这里不再重复。

图像的属性

用鼠标右键单击图像，从弹出的快捷菜单中选择“图片属性”命令，可以见到下图所示的对话框，在该对话框中可设置所选图像的一些属性。

在上图中所示的“位置尺寸”选项卡中可直接改变图像的位置，而改变“宽度”与“高度”内的值，就可直接将图片放大或缩小。

在“外观”选项卡中，可选择边线的类型、宽度、颜色。在“其它”选项卡中可设置“保护”和“不打印”。

系统目录


绘制按钮

OLE对象


New Page 3

插入对象

1) 单击“插入”菜单中的“OLE对象…” 命令，屏幕上弹出图1所示的对话框。

图1 插入OLE对象

2) 在该对话框中列出您的计算机中已经安装的OLE对象，选择其中的一个对象，单击“确定”按钮，就可打开与此对象相关的程序，插入OLE对象。

在图1所示的对话框中，有一个复选框叫做“显示为图标”。如果您首先选定“BMP图像”这个OLE对象，然后选定这一选项，最后单击“确定”，将出现图2所示的对话框。在办公之星的窗口上面出现一个新的窗口，在该窗口中画好各种图形后，单击“文件”菜单中的“退出并返回到Ost1”命令或直接在此窗口外空白处单击，在办公之星文档中将只显示出一个对象的图标，而不是已经绘制好的图形。如果以后要对图形进行修改，只要双击此图标编辑即可。

图2 将插入的OLE对象显示为图标

如果您在图1中没有选定“显示为对话框”这一项，将见到图3所示对话框。这时，办公之星的标题栏没有变化，但工具栏与都变成了OLE对象的工具栏与菜单。在我们这个例子里，都变成了Excel 2000的菜单与工具栏，而下面的编辑窗口中出现了一个虚线框，框内就是一个Excel 2000窗口，在窗口中可以直接往Excel表中输入数据、编辑公式、设置单元的属性。

图3 插入Excel表格

在输入、编辑完以后在Excel的窗口之外单击一下鼠标，就会退出Excel，恢复为办公之星的菜单与工具条，但在编辑窗口中将已显示出已插入的OLE对象－－Excel表格。在图4中，插入的Excel表格是以实际格式显示出来的，而插入的BMP图像只是一个图标。

图4 已经插入到文档中的两个对象

图标对象与对象之间的转换

如果将对象以图标形式插入到文档中，无法见到对象中的内容，也无法正常打印。因此，通常不要使用这种方式。如果要将已插入到文档中对象图标转换成普通图像，步骤是：

1）选定要转换的图标；

2） 右键单击图标，在弹出的快捷菜单中选择“BMP图像对象” ，又弹出一子菜单，从中选择“转换…”选项，弹出一对话框如图5所示：

图5 “转换”对话框

3） 在弹出的对话框中取消“显示为图标”前面的对号。选定对象就转换成普通的对象了。

编辑对象

如果要编辑已插入的对象，双击该对象，就可启动相关的OLE程序，根据插入的方式不同，出现不同的窗口，编辑完毕之后，采用上面介绍过的步骤返回到办公之星中。

办公之星对插入到文档中的OLE对象与图像、表格等都一视同仁，因此，用鼠标右键单击插入到文档中的对象，从出现的快捷菜单中同样可以设置这些对象的排版位置、对象层次。

如果您想删除插入的对象，选定此对象，按键盘上的 Delete 键即可。

系统目录


绘制按钮

旋转字


New Page 3

插入旋转字

“插入”菜单中选择“旋转字”命令，弹出一对话框，提示您输入旋转字的内容。该对话框非常的简单，只有一个文字框，即是旋转字的内容输入所在，您即使输入多个字，在生成的“旋转字”对象也只显示一个。

文字修饰

这时的旋转字同普通文字这方面的操作别无二致，选中“旋转字”对象后直接选择字号、字体、粗体、斜体、颜色即可，但不可对旋转字进行阴文、阳文等其它文字修饰。

旋转字的旋转

将旋转字选中，其左边有一绿色填充的黑边小圆点。将鼠标移近它，待鼠标变为一圆圈，按住鼠标拖动即可对“旋转字”进行旋转操作，旋转是以字中心为圆心进行的。

改变字内容

双击“旋转字”对象，重弹出插入旋转字时出现的对话框，可在文字框中输入内容。

系统目录


绘制按钮

电子印章


New Page 3

插入印章

1) 在“插入”菜单中选择“印章>圆形印章”命令；
2) 此时页面光标处出现一红色印章，同时出现一“定制印章”对话框如图1所示，在此对话框里我们可以对印章的内容、属性进行设置。下面将相关设置项介绍如下：

u 上绕文字：一个印章的主要内容，一般为公司或机构名称。在此选项中可对文字内容、大小、字与字之间的旋转角度、文字的环绕半径等属性进行设置：
 Ø 文字：在这里我们输入上绕文字的具体内容，一般为公司或单位的名称；
 Ø 字体：在这里对上绕文字的字体进行设置。系统默认的字体为宋体。单击右旁的下拉按钮，可对字体进行选择。可供选择的字体种类取决于您系统中已安装的字库。如果您安装了象篆书、草书之类的字体，那设计出的印章可就很有特色；
 Ø 字号：对上绕文字的大小进行设置。字号越大，字越大；
 Ø 间距：上绕文字字与字之间相对与印章中心的旋转角度。可以直接输入角度，也可以单击右旁的向上或向下按钮以１度为单位进行微调。20度或30度对于我们来说都很不形象，其实在弹出图1所示对话框的同时，在当前光标所在处也出现了一个印章。将对话框移到合适区域，边调边对照最后的效果，直至满意为止，这样直观多了；
 Ø 环绕半径：调整上绕文字所围绕的圆的半径，以毫米为单位。可以直接输入数值，也可以单击右旁的向上或向下按钮以0.1毫米为单位进行微调。
 Ø 在“字号”的右边还有两个可选项：加粗和字形 将它们选中可使上绕文字加粗或改变文字的长宽比。

u 外圆：可设置外圆的有无、环绕半径；
u 五角星：一个印章的标志，当然您也可以不显示它，这里的“半径”、“颜色”设置与“外圆”中一样；
u 印章颜色：印章一般为红色，也有蓝色的或其它颜色，在这里可自行设置，只要您喜欢；
u 设置密码：设置了密码的印章可以防止对印章的内容进行任何修改，防止印章被拷贝；
u 下绕文字：带下绕文字的印章不多见，其设置与“上绕文字”同；
 u 底额文字：其设置与“上绕文字”类同，有一点不同的是它不可以被改变“字与字之间的旋转角度”，可以改变的是距“外圆”上边界的距离；
u 防伪标识：这个可要记清楚，它就象您身份证号码；

图1 “定制印章”对话框

注意：“下绕文字”、“底额文字”、“防伪标识”三选项在“定制印章”对话框中点击“其它》”按钮后才可以被看到。设置好的印章如图2所示：

图2 设置好的印章

如果生成印章后要对它进行一些修改，只要双击印章，重弹出“定制印章”对话框，在里面进行设置即可。右键单击印章，在弹出的快捷菜单中可对印章进行剪切、复制等操作，这样的话，印章在别的软件中也可以派上用场了。

保存印章

设置好印章后，我们需保存起来供以后使用，如果说“插入印章”操作与刻印章类同的话，那么现在便是把这个刻好的印章保管起来。

1) 单击办公之星左边的和“文件库”在一起的“百宝箱”选项卡（如果该选项卡没有出现，请选择“视图”菜单中“工具条>文件库”命令）；
2) 单击印章，此时印章被选中，四周出现几个黑色操作点；
3) 在百宝箱的空白处右键单击，在弹出的快捷菜单中输选择“添加对象”即可。

印章使用

一份通知或启示编辑完成后，该轮到印章出场了：

1) 双击“百宝箱”中印章子项，例如“我的印章”，在当前光标处便出现您设置好的印章；

2) 拖动印章至合适位置；
3) 对着印章单击鼠标右键，在弹出的快捷菜单中选择“叠放次序”，在下一级菜单中有一些选项，您可据此调整印章与文字上下层之间的关系；
4) 从“插入”菜单中选择“页脚”，在页脚中输入提示文字告诉别人印章的标识号以便确认，如“该印章的防伪标识为：6435”。为了防止这些文字被打印，在页脚中单击右键，从弹出的快捷菜单中选择“文字框属性”，弹出一对话框，选择其中的“其它”选项卡，将其中的“不打印”选项选中；
5) 从“工具”菜单中选择“保护>保护文档”命令，在弹出的对话框中选择“只读保护”保护方式，在密码中输入密码，然后按“确定”按钮；

至此，您即可放心地将该通知或启示下发了。如果接收文件人员对该文件的有效性产生怀疑，核对一下印章的标识即可见分晓！

系统目录


绘制按钮

水印


New Page 3

所谓“水印”，就是指颜色较浅、较在的字设置于文字之下，并且出现在每一页上。例如，政府机关常常用“机密”、“绝密”等水印字。让我们看看有关操作步骤：

插入水印

选取“插入”菜单中“水印”命令，弹出一设置对话框（如图1所示）。在它左边是水印内容，例如“公司绝密”、“请勿带出”等，右边可对选中的水印内容进行字体、大小、排列位置设置。大小有三种可选：大型、标准、小型。可设置“倾斜”或“水平”两种排列位置方式输出。

图1 “水印”设置对话框

删除水印

在已插入水印的情况下，单击水印设置对话框左下边的“删除”按钮或将“水印文本”中内容删除即可。

打印水印

水印可看作背景，要打印或预览的时候，在弹出的“打印参数设置”对话框中将“打印页面背景”选项选中即可。

系统目录


办公之星帮助系统目录


第一章 OStar简介

第一部分 OStar简介

1.1 OStar简介

1.2 OStar屏幕组成

第二部分 OStar基本操作

2.1 欢迎屏幕

2.2 新建普通文件

2.3 利用模板创建新文件

2.4 打开文件

2.5 保存文件

2.6 设置文件密码与信息

2.7 标尺

2.8 页面设置

2.9 页眉与页脚

2.10 工作表操作

2.11 发送邮件

2.12 文件库

2.13 百宝箱

2.14 定制界面

第三部分 文字

3.1 文字框

3.2 文字处理

3.3 文字格式

第四部分 表格

4.1 创建表格

4.2 斜线表元

4.3 编辑表格数据

4.4 设置表元属性

4.5 修改表格

4.6 表格数据处理

第五部分 图表

5.1 创建图表

5.2 编辑图表

第六部分 图形编辑

6.1 绘制图形

6.2 选定图形对象

6.3 移动图形

6.4 复制图形

6.5 改变图形大小

6.6 对齐与排列

6.7 对象的层次

6.8 组合与分解

6.9 排版与绕排

第七部分 插入对象

7.1 图像与图像编辑

7.2 OLE对象

7.3 旋转字

7.4 电子印章

7.5 水印

第八部分 定制办公系统

8.1 绘制按钮

8.2 编辑按钮

8.3 自动指令

8.4 如何定制办公系统

第九部分 打印预览与输出

9.1 打印参数设置

9.2 打印机设置

9.3 打印预览